Help us develop the next-generation software, now in alpha!

Specify in the Logic Pro webpage or software page that it needs the beta software

The Saleae site says nowhere that beta software is needed to run the Logic Pro hardware. It is not at all intuitive that the beta software must be used. Definitely don't include the note to "update" to a version of the now unavailable software *a few versions older than the stable release* with the Logic Pro, when not even the stable release works for it.
Please add a note to the downloads page that the beta software is needed for the Logic Pro. Perhaps add a "select your device" tab.

  • MW
  • Jul 11 2018
  • Needs review